MiWaters System Requirements

MiWaters has been tested and will work with Internet Explorer 10 or 11 (preferred) and current versions of Chrome and Firefox.  Initial testing of Microsoft Edge has not uncovered any problems.

Known incompatibilities:

  • Internet Explorer 8 or earlier will not work with MiWaters.
  • Safari will not work with MiWaters' forms.