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Advanced Search Feature

Article Inside this Issue!
“Both state employees and citizens have

been asking for a better search feature on

the Michigan.gov Web portal. | am very

happy that our team was able to answer the

call and improve service.”

-- Lucy Pline, EWD Manager

News for Web Masters and CMA Users

Welcome to the December 2003 Meeting!

We are pleased to host this CMA Users and Webmasters Meeting!
Today’s session focuses on these key topics: the Inktomi searching,
PDF files, security and cybersquatting. We hope you pass this
information up the chain and across your enterprise for the benefit of
all State employees and your customers.

Security and Web Design
Rick Wolfinger, Enterprise Security

Rick Wolfinger
began his security
career in 1983
working for the
U.S. Air Force in
Electronic Security
Command (Japan).
He was responsible
for computer and communications
systems on SAC Airborne
Command Post aircraft and National
Emergency Airborne Command

Post aircraft. He worked as defense
contractor in England and Denver,
Colorado supporting United States
Department of Defense. Rick joined
State of Michigan October 2002.

The State of Michigan faces threats
to its IT security daily. Typical
incidents per day include:

¢ 1500 e-mail viruses

e 38,000 scans/probes

¢ 620 web server attacks

e 3 computer hack attempts

There are many ways we as
employees can help stem the
attacks and preserve our enterprise
security. One of the main ways
we can safeguard our applications
and network is by adopting good
password standards.

Some examples of BAD password
design exist as we speak. Some
actual cases include:

e “If you answer yes to one on-
line question, a password will be
automatically sent to you.”
¢ Application designed to accept a
password one character long.
e Application designed to accept Social
Security Number as password.
When the Enterprise Security
Team reviews Web applications for
security, the use of passwords will
be reviewed the issues that need to
be resolved. Among other review
criteria will be an Application Review
Security Checklist, adherance to the
following State Policies:

¢ 1410.17 Michigan State Government
Network Security Policy (section 6.6
for password information)

e 1310.16 Acceptable Use of the State
Telecommunications Network

¢ 1460.00 SOM Acceptable Use Policy

e State of Michigan Privacy Policy which
is attached to the Michigan.gov footer
on all Agency and application Web
sites.

A new Web site will soon be

available. MOST stands for Michigan

Online Security Training. The site,

w3.michigan.gov/most, is being

developed by Enterprise Security

in cooperation with Walsh College.

This site is being designed to

increase awareness and knowledge

of security for SOM employees. The

Web-based program contains basic

security concepts and a test-your-

knowledge module.

Look for “Al” the owl to help you be
“Security Wise!”
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Preflight Check List for PDF files

Before putting PDF
documents on a Web
site:

e Check to see that
the text, artwork,
and layout in the
documents are
complete and
correct, and that all links, bookmarks, and other
enhancements are in place.

e The documents should be at the point where you
would print them if you were distributing on paper.

¢ File Names: When naming a PDF document that
is going to be distributed electronically, it's a good
idea to follow naming conventions:

o Use only alpha characters, the underscore
(L), and digits (0-9).

o For aid in searching: use your agency
acronym as a prefix to the file name:
Example: DITtrainingnews.pdf

¢ File Size: Use the optimization tools available in
Acrobat and think about your customer.

o Many customers will still be using dialup
connections.

o Test your files at home with your service
provider.

o Instead of distributing one large document,
distribute a collection of small documents with
links between them.

o Small documents open faster than large ones,
and with links between them, users can go
straight to the relevant information.

Optimizing Files for the Web View

There are a few ways to optimize your files to
make them easier and faster to download for your
customers.

To optimize PDF files in Acrobat 5.0:
1. Open the PDF file in Acrobat, and choose Edit >
Preferences > General.

2. Select Options in the left panel of the Preferences
dialog box.

3. Select Save As Optimizes for Fast
Web View, and then click OK.

4. Choose File > Save As.
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To optimize PDF files in Acrobat 4.x:
1. Open the file in Acrobat 4.x, and
choose File > Save As.

Bath Procesing
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2. Select Optimize in the Save As Prirt..
dialog box, and then click Save. T -|

3. Click Yes to replace the existing
file.

How to Set Document Preferences:
EDIT/PREFERENCES/GENERAL

Many of the items in the check list can be done using the
tools in Acrobat. Look at the top menu in Acrobat. Click
on EDIT/PREFERENCES/GENERAL

Accessibility can set some options on your document
to help make it more accessible to those with disabilities.

Display is where you can set a number of options:

Single page, continuous ot
continuous facing pages

| o} Set the default
zoom: Select from
different font in the page
or percentage of zoom.
Options allows you to set
Browser Settings, whether
you want a splash screen
at startup and some other
settings aimed at more
usable documents.

FILE /| DOCUMENT
PROPERTIES
Summary: This pane
shows you what the
document metadata
contains. The document
metadata is the
information grabbed

by the search engine
and displayed as search
results.

| Accessibility

I Display

I Options

I TouchUp

You can also look at
the metadata using the
Document Metadata
Pane

Open Options: is another
place where you can

set how you want your
documents to open.
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Notes:

CMA Updates
Rick Peterson has made the following CMA updates
since the last meeting.

KEYWORDS: When Editing Content, you will notice an
input field for Keywords. This field is used to generate
the Meta tag for keywords which appears in the
<head> portion of document. The KEYWORDS metatag
is instrumental in improving search results. The “Short
Display Text” field for Categories is used for the same
purpose. This assists in improving the Inktomi search
results by allowing a search based on keywords. In
conjunction with this, an enhanced, advanced search
form was developed.

MORE STATE WEB SITES- The State Web Sites listing
has been modified to include “Other” sites, such as
redirects and special non-Agency sites, special interest
sites and non-Vignette sites. Site Admins, contact your
EMI Admin for more information.

ONLINE SERVICES COMPONENT The “"On-Line
Services” type component (List with More) is available
for use Agency sites. Watch for the new template
instructions on the e-Michigan site.

PREVIEW CATEGORY PAGE: Browse Categories now
has preview of Content and Nav categories. The LIVE/
IN_PROGRESS indicator will be a link to preview the
navigational categories.

MOVE CONTENT: To allow for bulk moving of content
items. This will shorten the process of updating the
Primary Category for multiple pieces of content. The
Ciontent listed for categories now displays check
boxes for content (Only when Primary Category ID is
ID of Category being browsed). Content is moved by
checking the box (a Select All/Deselect All checkbox

is available) and clicking the Move button. Use the
Category select process (top level category, then
primary category) select the destimnation category.

The content is associated to the newly select category.
Any existing workflow is not modified. Another
checkbox allows the user to keep the current category
association. This enables the content to be displayed in
both categories, the original content Category and the
newly selected Primary Category.

REPURPOSE CONTENT: Associate content from other
agencies to your categories. When Viewing General
Content Index, the grayed-out “Edit” is now a link to
“View” the content. Clicking on “View” takes you to
the View Content Item page. At the page bottom are
listed the Associated Categories. Clicking on “Add"” will
take you through the Add New Association CATEGORY
process. The content appears in your category layout
as well.

LINKS TO ASSETS OR CONTENT SHORTCUT:
Previously, a user needed to add or edit an asset and
copy the path generated and paste the path in the Link
field or a Link type content item. Or, preview or browse
to a piece of content and copy the URL to it. Now, a
shortcut process was added for Link (URL). Enter a
Content or Asset ID in the Link (URL) field, make the
appropriate Content/Asset ID selection and Update

the content. The code will automatically generate the
formatted relative URL for the content or asset ID

that you entered. This only happens when you enter

a number in the field. If you enter a number in the
field and do not select Content or Asset, Content is the
default.

WORKFLOW/CACHING FIX: Workflow Transaction
=> Added new feature to check Category and Site
status for LIVE content category associations. For
each association, if both statuses are live, smart cache
management records are added to the cache table.
This should address a caching situation where content
is pushed through workflow and the release date has
already passed.
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The Pitfalls of Domain Ownership
Don’t become a “cybersquatting” victim!

Ric Tombelli, e-MI Webmaster

Many agencies throughout the state have, over time,
accumulated a lot of domain names. These allow an
agency to point or direct users to a particular URL
that reflects and specific acronym, program name or
specialized task force or committee.

These seem harmless to the user, the state agency
and to most of us that have grow so accustomed to
surfing the web for all our information needs. In fact
a look at the state’s external proxy server that routes
domain names shows that we currently maintain well
over 200 distinctive domain names that have been
custom ordered by agencies.

Some like (and I'm not trying to single anyone out
here)...

http://www.mi529prepaid.org
http://www.mich-freedomacademy.org
http://www.mesb.org
http://www.2649.0rg
http://www.bingedrink.com
http://mi529prepaid.com
http://metd4kid.com
http://mimhefa.org

These domain names have been purchased using
popular domain services like register.com, tucows.com
and others. The cost is nominal, starting at just
$35.00 and ranging up to over $150.00 depending

on how long the agency plans on keeping it active. If
you did some quick math, 200 domain names at an
average of $75.00 per year costs the state $15,000.

These domains serve a useful purpose, albeit a
dubious one, in that they do provide an easy,
memorable way to get average web users to identify
with a government program and get to the web site
that supports it.

After all, marketing URLs should be easy to remember
and easy to type. These domain names certainly
accomplish that — and only that.

But with all the good they do, the state has started
seeing some dark sides to domain names. What
happens to a domain name when it’s no longer
needed, or the program goes away, or the task force
accomplishes what it set out to do? What happens
to all the sites that may have linked to the domain
name, including library and school computers that
have the sites book marked? What difference does it
make after all?
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The dark side of domain names is that they are
actively being sought by some of the abusers of the
Internet world. These are companies or individuals
who seek to exploit, extort or otherwise high-jack
legitimate domain names for their own use. The
domain name in its original form is snatched up only
to lead users to a site that they have no idea that are
connecting to. The idea is that once there, the user
will decide to stay a while and visit, hopefully long
enough to be lured into returning later, or to start
making money transactions on the spot.

These domain names look totally normal in the
favorites menu as well, and anyone briefly looking
through or scanning access log files would never
notice them.

Cyber-squatting (a term that has been used to define
this activity) refers to companies or individuals who
prey on expired domain names and buy them up,
only to leave the domain name and even page titles
exactly as it they are. This fools site crawlers and
automated filters from even detecting that they are in
fact illegitimate sites and contain the most offensive
material.

To buy the domains names back, the original owners
are required to pay thousands of dollars or face

the continued bane of having their once legitimate
program abused by an offensive material. Legally,
there is absolutely nothing that can be done.

To counter this, agencies are being encouraged to
refrain from purchasing specialty domain names

that need to be maintained forever in order to be
preserved, even after they have served their purpose.
Agencies should use legitimate domain naming
conventions that the state has already put in place to
protect the state from this abuse.




Agencies should try to use the approved domain
name of state.mi.us in all their agency specific
applications.

http://www.state.mi.us/webapp/
http://www.state.mi.us/folio
http://www.state.mi.us/gw5
http://www.state.mi.us/hdamk
http://www.state.mi.us/mitownhall
http://www.state.mi.us/msp/crd
http://www.state.mi.us/msp/ohsp/

In addition, the Michigan.gov domain has been
made available to all state agencies that wish to
market their program or office to allow direct, safe,
accurate and maintainable domain names and URLs
that can be completely controlled by the state. This
also places the site into the state’s search engine
and will increase the likelihood of it being found.

http://www.michigan.gov/jointpermit
http://www.michigan.gov/wdl
http://www.michigan.gov/lyme
http://www.michigan.gov/fostercare
http://www.michigan.gov/osteoporosis
http://www.michigan.gov/westnilevirus
http://www.michigan.gov/metro

These domain names and URLs are designed to
be permanent and never require renewal. In fact
the Michigan.gov marketing URLs are FREE. They
can be changed at any time and if they need

to be decommissioned, they will never ever fall
into the hands of extortionists. In addition, DIT
Infrastructure Services and telecom can set up a
standard domain name sing state.mi.us for your
DMZ hosted or agency-hosted servers. All of this
is maintained in house and will never expose the
state to unwanted domain name usage or politically
embarrassing situations.

More importantly, the citizens and school children
of the state will be spared from unexpectedly
visiting one of these offensive sites when accessing
legitimate state content.

Advanced Search Features

In response to requests for an improved search
feature, the e-Michigan Web Development team has
recently added new options to the advance search
feature, which will allow site visitors to more easily
find the information they are seeking. Users are now
able to use three levels of search criteria.

First Search Criteria

e Must contain a specific phrase

e Should Contain a specific phrase

e Must Not Contain a specific phrase

Second Search Criteria

¢ in the body of the Web content

in the title of the Web content

in the URL (web address)

in the keywords of the Web content
in the description of the Web content

Third Search Criteria
e the words

¢ the phrase

e the name

Users can now search for types of documents, such
as Microsoft Office files, Acrobat files, text files or
documents in Rich Text Format. The search can be
done within a specific agency site or its navigational
categories, or the entire Michigan.gov portal.

To access the advanced search feature, users simply
enter any search word or phrase into the search field
and click the <go> button. After the initial search
results page is displayed (Figurel), users should
notice an Advanced Search button in bright yellow.
Clicking on this will bring them to the new advanced
search page along with their original search criteria.
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Webmaster Quarterly Meeting Evaluation

December 11, 2003

Highest
5

4

2

Lowest
1

N/A

The objectives of the meeting were clear:

The meeting met its stated objectives:

The presenters were well prepared:

The materials provided were useful and effective:

The pace and organization was appropriate:

Questions and concerns were addressed appropriately:

How well did each topic address concerns or answer
questions?

e John Thompson: Inktomi Searh

e Anne Nolan: PDF- Searching and File Sizes

e Tina Stojakavich: Emerging Diseases Web Site

¢ Rick Wolfinger: Security and Web Design

e Ric Tombelli: Domain Names & Cybersquatting

Is the frequency of meetings appropriate?
U Just right, don’t change it.
O We need to meet more often. How often?

O We need to meet less often. How often?

U We don’t need to meet at all.

Questions or issues you expected to be addressed that weren’t:

Topics you would like to see covered at future meetings:

Would you like to see more mini-meetings like the ADA presentation? If so, suggest a topic.

Would you be willing to present your site at a future meeting? Please include:

Your Name:
Site Name:
Phone Number:

Additional comments:




