Browser Compatibility

MET ENROLLMENT IS CLOSED

 

BROWSER COMPATIBILITY FOR MET’S ONLINE CONTRACT ENROLLMENT WEBSITE


Supported Browsers

Online Contract Enrollment is designed for use with Internet Explorer version 7.0 or higher and Firefox version 7.0 and higher.


Unsupported Browsers

Microsoft Edge, Google Chrome (Android tablets and phones) and Apple Safari (iPads, iPhones) are not supported and unsuccessful enrollments have been reported attempting to use these browsers.

 

PROCEED TO ONLINE ENROLLMENT