Do I have to use a specific Internet browser to access the MCOLES Network?

The web modules of the MCOLES Network were designed for Internet Explorer. Even though another browser may allow access to the Web pages, MCOLES cannot ensure that the pages will function properly. Therefore, it is strongly recommended that IE 6.0 (or higher) be used to access the Network. Internet Explorer can be downloaded free of charge from Microsoft at www.microsoft.com.